<!doctype html>
<html lang="en">
<head>

<meta charset="utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<meta http-equiv="X-UA-Compatible" content="ie=edge">
<meta name="microtip" content="33NWbMsckoLcoVX6Tz9o6ksuBrJVeu3en2" data-currency="btc">
<meta name="theme-color" content="#ffffff">

<link rel="preconnect" href="https://srv.buysellads.com" crossorigin>
<link rel="preconnect" href="https://www.google-analytics.com" crossorigin>
<link rel="preconnect" href="https://www.google.com" crossorigin>
<link rel="preconnect" href="https://googleads.g.doubleclick.net" crossorigin>
<link rel="preconnect" href="https://cdn.ampproject.org" crossorigin>
<link rel="preconnect" href="https://s3.amazonaws.com" crossorigin>
<link rel="preconnect" href="https://cdn.digg.com" crossorigin>
<link rel="preconnect" href="https://assets.digg.com" crossorigin>
<link rel="preconnect" href="" crossorigin>
<link rel="prerender" href="/video">
<link rel="prerender" href="/gaming">
<link rel="prerender" href="/digg-picks">
<link rel="prerender" href="/sports">
<link rel="prerender" href="/longreads">
<link rel="prerender" href="/technology">
<link rel="prerender" href="/culture">
<link rel="prerender" href="/science">
<link rel="prerender" href="/photos">

<meta name="fo-verify" content="086e7e50-6613-44aa-8f1f-16ef9f992a1f">

<link rel="manifest" href="/manifest.json?v=1655212101">
<link rel="canonical" href="https://digg.com/memes-ranked/link/deuxmoi-s-identity-revealed-it-s-morbin-time-and-this-week-s-other-best-memes-ranked-M3THxre5uV">
<meta name='robots' content='max-image-preview:large, max-snippet:-1, max-video-preview:-1'>

<link rel="stylesheet" href="https://cdn.digg.com/styles/digg.css?v=1655212101">

<link rel="stylesheet" href="/fragments/components/main-navigation/static/main-navigation.css?v=1655212101">

<link rel="stylesheet" href="/fragments/components/ads/static/ads.css?v=1655212101">


<script>
    window.digg = {};
  </script>

<link rel="icon" href="/static/images/digg-favicon.png?v=1655212101" type="image/png">
<link rel="apple-touch-icon" href="/static/images/digg-logo-512.png?v=1655212101">
<script type='text/javascript'>
    window.optimize = window.optimize || { queue: [] };
  </script>

<script type='text/javascript'>
    (function () {
      var _sf_async_config = window._sf_async_config = (window._sf_async_config || {});
      _sf_async_config.uid = 30608;
      _sf_async_config.domain = 'digg.com';
      _sf_async_config.flickerControl = false;
      _sf_async_config.useCanonical = true;
      _sf_async_config.useCanonicalDomain = true;
      _sf_async_config.sections = ''; //CHANGE THIS TO YOUR SECTION NAME(s)
      _sf_async_config.authors = '@molly-bradley'; //CHANGE THIS TO YOUR AUTHOR NAME(s)
      function loadChartbeat() {
        var e = document.createElement('script'); e.type = 'text/javascript'; e.async = true; e.src = '//static.chartbeat.com/js/chartbeat.js';
        var n = document.getElementsByTagName('script')[0]; n.parentNode.insertBefore(e, n);
      }
      loadChartbeat();
    })();
  </script>
<script async src="https://static.chartbeat.com/js/chartbeat_mab.js"></script>

<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:site" content="@digg">
<meta name="twitter:title" content="Deuxmoi&#039;s Identity Revealed, It&#039;s Morbin&#039; Time And This Week&#039;s Other Best Memes, Ranked - Digg">
<meta name="twitter:image" content="https://cdn.digg.com/submitted-links/1653572435-DFjybLGhL2.jpg">
<meta name="twitter:description" content="This week, we&#039;ve also got people dunking on new photos of Gorr the God Butcher in &quot;Thor: Love and Thunder.&quot;">
<meta property="fb:app_id" content="246440939021950">
<meta property="og:url" content="https://digg.com/memes-ranked/link/deuxmoi-s-identity-revealed-it-s-morbin-time-and-this-week-s-other-best-memes-ranked-M3THxre5uV">
<meta property="og:type" content="article">
<meta property="og:title" content="Deuxmoi&#039;s Identity Revealed, It&#039;s Morbin&#039; Time And This Week&#039;s Other Best Memes, Ranked - Digg">
<meta property="og:image" content="https://cdn.digg.com/submitted-links/1653572435-DFjybLGhL2.jpg">
<meta property="og:description" content="This week, we&#039;ve also got people dunking on new photos of Gorr the God Butcher in &quot;Thor: Love and Thunder.&quot;">
<meta name="application-name" content="Digg">
<meta name="msapplication-TileImage" content="https://digg.com/static/images/digg-logo-144.png">
<meta name="msapplication-TileColor" content="#ffffff">
<title>Deuxmoi&#039;s Identity Revealed, It&#039;s Morbin&#039; Time And This Week&#039;s Other Best Memes, Ranked - Digg</title>
<meta name="description" content="This week, we&#039;ve also got people dunking on new photos of Gorr the God Butcher in &quot;Thor: Love and Thunder.&quot;">
<meta name="keywords" content="">
<meta name="author" content="@molly-bradley">

<link rel="search" type="application/opensearchdescription+xml" title="Digg" href="/opensearch.xml">

<script async src="https://www.googletagmanager.com/gtag/js?id=UA-33556916-1"></script>
<script>
    window.dataLayer = window.dataLayer || [];
    function gtag() {
      dataLayer.push(arguments);
    }
    gtag('js', new Date());
    gtag('config', 'UA-33556916-1', {
      'custom_map': {
        'dimension7': 'user_login_status'
      }
    });

          gtag('event', 'page_load', { 'user_login_status': 'no' });
      </script>

<style>
    
  </style>
</head>
<body itemscope itemtype="https://schema.org/WebPage" class="tailwind ">
<script>
    window.isCallerMobile = false;
  </script>
<header class="fixed top-0 left-0 right-0 z-40 bg-white primary-navigation transition duration-1000 ease-in-out">
<div class="ads-homepage-leaderboard-atf flex">

<div id="bsa-zone_1593722135885-4_123456" data-explicitly-hidden="data-explicitly-hidden"></div>
</div>
<section class="flex items-center justify-between text-base border-b primary border-digg-gray-lightest sm:h-16">
<nav class="hidden w-1/3 m-4 text-left lg:ml-8 sm:block">
<a class="mr-2 lg:mr-6 hover:text-digg-blue" href="/namespaces">Explore</a>
<a class="mr-2 lg:mr-6 hover:text-digg-blue" href="https://merch.digg.com">Merch</a>
</nav>
<div class="w-1/2 m-4 sm:w-1/4 header-logo">
<a href="/" class="flex sm:justify-center align-center">
<svg viewBox="0 0 47 27" width="47" height="27" xmlns="http://www.w3.org/2000/svg" aria-label="Digg">
<path d="M5.025 10.025H7V17H5.025v-6.975zM0 21h12V0H7v6H0v15zM14 6h5v15h-5zm0-6h5v4h-5zm12 10h2v7h-2v-7zm-5 11h7v2h-7v4h12V6H21v15zm19-11h2v7h-2v-7zm-5 11h7v2h-7v4h12V6H35v15z" fill="#1B1A19" fill-rule="evenodd"></path>
</svg>
</a>
</div>
<nav class="relative flex items-center hidden w-1/3 m-4 text-right sm:block lg:mr-8 nav-top-right">
<span class="inline-block ml-1 align-middle cursor-pointer lg:ml-2 link-open-signin-modal">
<a title="Submit a link" class="block px-1 py-1 rounded-full bg-digg-blue-lighter text-digg-blue" data-href="/news&amp;isl=1">
<svg xmlns="http://www.w3.org/2000/svg" class="w-4 h-4" fill="none" viewBox="0 0 24 24" stroke="currentColor">
<path stroke-linecap="round" stroke-linejoin="round" stroke-width="2" d="M12 4v16m8-8H4" />
</svg>
</a>
</span>
<span class="inline-block ml-1 lg:ml-2 align-middle cursor-pointer link-open-signin-modal">
<a title="Leaderboard" data-href="/leaderboard">
<svg xmlns="http://www.w3.org/2000/svg" class="w-6 h-6" fill="none" viewBox="0 0 24 24" stroke="currentColor">
<path stroke-linecap="round" stroke-linejoin="round" stroke-width="2" d="M17.657 18.657A8 8 0 016.343 7.343S7 9 9 10c0-2 .5-5 2.986-7C14 5 16.09 5.777 17.656 7.343A7.975 7.975 0 0120 13a7.975 7.975 0 01-2.343 5.657z" />
<path stroke-linecap="round" stroke-linejoin="round" stroke-width="2" d="M9.879 16.121A3 3 0 1012.015 11L11 14H9c0 .768.293 1.536.879 2.121z" />
</svg>
</a>
</span>
<span class="activity inline-block ml-1 lg:ml-2 align-middle cursor-pointer link-open-signin-modal">
<a title="Activity" data-href="/activity">
<svg xmlns="http://www.w3.org/2000/svg" class="w-6 h-6" fill="none" viewBox="0 0 24 24" stroke="currentColor">
<path stroke-linecap="round" stroke-linejoin="round" stroke-width="2" d="M15 17h5l-1.405-1.405A2.032 2.032 0 0118 14.158V11a6.002 6.002 0 00-4-5.659V5a2 2 0 10-4 0v.341C7.67 6.165 6 8.388 6 11v3.159c0 .538-.214 1.055-.595 1.436L4 17h5m6 0v1a3 3 0 11-6 0v-1m6 0H9"></path>
</svg>
</a>
</span>
<span class="inline-block ml-1 lg:ml-2 align-middle cursor-pointer link-open-signin-modal">
<a title="Sign in" data-href="/">
<svg xmlns="http://www.w3.org/2000/svg" class="w-6 h-6" fill="none" viewBox="0 0 24 24" stroke="currentColor">
<path stroke-linecap="round" stroke-linejoin="round" stroke-width="2" d="M5.121 17.804A13.937 13.937 0 0112 16c2.5 0 4.847.655 6.879 1.804M15 10a3 3 0 11-6 0 3 3 0 016 0zm6 2a9 9 0 11-18 0 9 9 0 0118 0z" />
</svg>
</a>
</span>
</nav>
<div class="w-1/2 m-3 text-right hamburger sm:hidden">
<a class="icon">
<svg width="27" height="27" class="inline-block ml-2 hover:text-digg-blue" version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" viewBox="0 0 50 50" enable-background="new 0 0 50 50" xml:space="preserve">
<path fill="#231F20" d="M8.667,15h30c0.552,0,1-0.447,1-1s-0.448-1-1-1h-30c-0.552,0-1,0.447-1,1S8.114,15,8.667,15z"></path>
<path fill="#231F20" d="M8.667,37h30c0.552,0,1-0.447,1-1s-0.448-1-1-1h-30c-0.552,0-1,0.447-1,1S8.114,37,8.667,37z"></path>
<path fill="#231F20" d="M8.667,26h30c0.552,0,1-0.447,1-1s-0.448-1-1-1h-30c-0.552,0-1,0.447-1,1S8.114,26,8.667,26z"></path>
</svg>
</a>
</div>
<div class="relative hidden w-full mobile-menu">
<div class="flex items-center p-4 text-center _justify-center">
<svg viewBox="0 0 47 27" width="47" height="27" xmlns="http://www.w3.org/2000/svg" aria-label="Digg">
<path d="M5.025 10.025H7V17H5.025v-6.975zM0 21h12V0H7v6H0v15zM14 6h5v15h-5zm0-6h5v4h-5zm12 10h2v7h-2v-7zm-5 11h7v2h-7v4h12V6H21v15zm19-11h2v7h-2v-7zm-5 11h7v2h-7v4h12V6H35v15z" fill="#1B1A19" fill-rule="evenodd"></path>
</svg>
</div>
<hr>
<nav class="p-4">
<a class="block p-2 px-6" href="/namespaces">Explore</a>
<a class="block p-2 px-6" href="https://merch.digg.com">Merch</a>

<span class="block p-2 px-6 cursor-pointer link-open-signin-modal">Sign in</span>
<a class="absolute block p-6 close-mobile-menu -top-1 -right-2">
<svg class="inline" xmlns="http://www.w3.org/2000/svg" width="18" height="18" viewBox="0 0 24 24">
<path id="x" d="M18.717 6.697l-1.414-1.414-5.303 5.303-5.303-5.303-1.414 1.414 5.303 5.303-5.303 5.303 1.414 1.414 5.303-5.303 5.303 5.303 1.414-1.414-5.303-5.303z" />
</svg>
<span class="hidden">Close menu</span>
</a>
</nav>
</div>
</section>
<section class="flex items-center justify-center text-base border-b secondary border-digg-gray-lightest whitespace-nowrap sm:px-4 sm:h-12">
<div class="overflow-hidden invisible-scrollbars">
<div class="overflow-x-auto">


<a class="inline-block m-4 hover:text-digg-blue" href="/popular">
<div class="flex items-center">
<span class="inline-block">Popular</span>
<svg class="inline-block w-5 ml-1 text-black _text-digg-blue" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 20 20" fill="currentColor">
<path fill-rule="evenodd" d="M12 7a1 1 0 110-2h5a1 1 0 011 1v5a1 1 0 11-2 0V8.414l-4.293 4.293a1 1 0 01-1.414 0L8 10.414l-4.293 4.293a1 1 0 01-1.414-1.414l5-5a1 1 0 011.414 0L11 10.586 14.586 7H12z" clip-rule="evenodd" />
</svg>
</div>
</a>
<a class="inline-block m-4 hover:text-digg-blue" href="/video">Video</a>
<a class="inline-block m-4 hover:text-digg-blue" href="/gaming">Gaming</a>
<a class="inline-block m-4 hover:text-digg-blue" href="/digg-picks">Picks</a>
<a class="inline-block m-4 hover:text-digg-blue" href="/sports">Sports</a>
<a class="inline-block m-4 hover:text-digg-blue" href="/longreads">Long Reads</a>
<a class="inline-block m-4 hover:text-digg-blue" href="/technology">Tech</a>
<a class="inline-block m-4 hover:text-digg-blue" href="/culture">Culture</a>
<a class="inline-block m-4 hover:text-digg-blue" href="/science">Science</a>
<a class="inline-block m-4 hover:text-digg-blue" href="/relationships">Relationships</a>
</div>
</div>
</section>
</header>
<div class="mt-32">
<style>
    :root {
      --namespace-primary-color: #E77718;
      --namespace-secondary-color: #E77718;

      --namespace-primary-background: #E77718;
      --namespace-secondary-background: #E77718;

      --namespace-primary-background-transparent: #E7771810; /* last two digits are alpha channel */
      --namespace-secondary-background-transparent: #E7771810; /* last two digits are alpha channel */
    }
  </style>
<style>
  .namespace-primary-text { color: var(--namespace-primary-color) !important; }
  .namespace-primary-background { background-color: var(--namespace-primary-background) !important; }
  .namespace-primary-background-transparent { background-color: var(--namespace-primary-background-transparent) !important; }
  .namespace-primary-border { border-color: var(--namespace-primary-color) !important; }

  .namespace-secondary-text { color: var(--namespace-secondary-color) !important; }
  .namespace-secondary-background { background-color: var(--namespace-secondary-background) !important; }
  .namespace-secondary-background-transparent { background-color: var(--namespace-secondary-background-transparent) !important; }
  .namespace-secondary-border { border-color: var(--namespace-secondary-color) !important; }
</style>
<script>
  window.namespaceSlug = "memes-ranked";
</script>
<main class="container-1400 mx-auto px-4 py-0 md:px-8 md:py-4 text-base view-single view-link below-leaderboard-atf">
<div class="flex space-x-0 lg:space-x-8 flex-wrap lg:flex-nowrap">
<section class="w-full lg:w-72 flex-shrink-0">
<div class="block lg:sticky lg:top-36 flexbar-sticky-offset">
<div class="relative md:border border-l-0 rounded-l-none p-0 md:p-4 rounded overflow-hidden">
<div class="absolute inset-y-0 left-0 w-0 md:w-1 h-full namespace-primary-background"></div>
<div class="hidden lg:block">
<div class="namespace-badge relative font-mono inline-block p-2 py-0 mb-6 text-xs">
<div class="absolute inset-0 rounded-full opacity-5 namespace-primary-background"></div>
<span class="namespace-primary-text">36
members</span>
</div>
</div>
<div>
<p class="mt-2 mb-1 lg:mt-2 lg:mb-2 text-xl font-bold hover-primary-text namespace-sidebar__name">
<a href="/memes-ranked" title="Memes, Ranked">Memes, Ranked</a>
</p>
</div>
<div class="hidden lg:block">
<p class="leading-5 mb-4 text-digg-gray namespace-sidebar__description">A weekly ranking of the funniest, most versatile and most confounding memes that cross the timeline.</p>
</div>
<div class="hidden lg:block">
<div class="flex overflow-hidden flex-row flex-wrap">
</div>
</div>
</div>
<div class="namespace-scheme hidden lg:block mt-6">
<a class="border namespace-primary-border namespace-primary-text subscribe cursor-pointer max-w-64 text-center px-6 py-3 rounded-full inline-block link-open-signin-modal" data-href="/memes-ranked/join">Join
Memes, Ranked</a>
</div>
</div>
</section>
<section class="flex-grow min-w-0 namespace-submitted-links">
<style>
  .editor-toolbar {
    border-top: 1px solid rgba(229, 231, 235, var(--tw-border-opacity)) !important;
    border-bottom: 1px solid rgba(229, 231, 235, var(--tw-border-opacity)) !important;
    border-left: none !important;
    border-right: none !important;
    border-top-left-radius: 0 !important;
    border-top-right-radius: 0 !important;
  }

  .CodeMirror {
    border: none !important;
    border-bottom-left-radius: 0 !important;
    border-bottom-right-radius: 0 !important;
  }

  /* https://stackoverflow.com/questions/69296163/contenteditable-removes-trailing-whitespaces-on-firefox-but-not-on-chrome */
  div[contenteditable="true"] {
    white-space: pre-wrap;
    word-break: break-word;
  }
</style>
<div id="form-inline-edit" style="display: none;" class="mt-2 relative" data-render="body">
<div v-if="statusShowForm" class="pb-6 bg-white">
<div class="rounded border border-digg-gray-lightest">
<div class="w-full max-w-full relative flex-col md:flex-row flex gap-0 md:gap-4 p-4">
<div class="flex-grow order-last md:order-first  min-w-0">
<div v-if="submissionType == 'image'" class="pb-4">
<div class="relative">
<label for="ief-image-input" class="cursor-pointer block">
<span v-if="statusImageLoaded || imageUrl == DEFAULT_SUBMIT_IMAGE" class="bg-digg-blue absolute top-2 right-2 flex justify-center items-center rounded-full w-6 h-6">
<svg height="14px" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" viewBox="0 0 22 22">
<path d="M8,0 L14,0 L14,3 L8,3 L8,0 Z M8,5 L14,5 L14,19 L11,22 L8,19 L8,5 Z" fill="#fff" transform="translate(11.000000, 11.000000) rotate(45.000000) translate(-11.000000, -11.000000) " /></g>
</svg>
</span>
<img @load="handleImageLoaded" v-if="imageUrl != DEFAULT_SUBMIT_IMAGE" :src="imageUrl" :alt="title" class="border-2 border-dashed border-digg-blue w-full h-full rounded object-cover max-w-none max-h-none bg-digg-gray-clear" />
<span v-if="imageUrl == DEFAULT_SUBMIT_IMAGE" class="bg-digg-blue-lighter flex flex-col py-32 items-center justify-center rounded w-full">
<svg width="54" height="40" xmlns="http://www.w3.org/2000/svg">
<g><rect fill="none" fill="#005be2" height="32" width="46" y="-1" x="-1" /></g>
<g><path stroke-width="0" fill="#005be2" fill-rule="evenodd" d="m39.623991,25.714625l-6.334,-6.334l-3.619,3.619l3.334,3.334c0.381,0.381 0.381,0.999 0,1.381c-0.382,0.381 -1,0.381 -1.381,0l-14.334,-14.334l-12.334,12.334c-0.381,0.381 -0.999,0.381 -1.381,0c-0.381,-0.382 -0.381,-1 0,-1.381l12.905,-12.905c0.032,-0.048 0.053,-0.101 0.095,-0.144c0.197,-0.197 0.457,-0.287 0.715,-0.281c0.258,-0.006 0.518,0.084 0.715,0.281c0.042,0.043 0.062,0.096 0.095,0.144l10.19,10.19l4.19,-4.19c0.033,-0.047 0.053,-0.101 0.095,-0.144c0.197,-0.196 0.457,-0.287 0.715,-0.281c0.258,-0.006 0.518,0.085 0.715,0.281c0.042,0.043 0.062,0.097 0.095,0.144l6.905,6.905c0.381,0.381 0.381,0.999 0,1.381c-0.382,0.381 -1,0.381 -1.381,0zm-12.334,-15.715c-2.209,0 -4,-1.791 -4,-4s1.791,-4 4,-4s4,1.791 4,4s-1.791,4 -4,4zm0,-6c-1.104,0 -2,0.896 -2,2s0.896,2 2,2s2,-0.896 2,-2s-0.896,-2 -2,-2z" clip-rule="evenodd" /></g>
</svg>
<span class="text-xs text-digg-blue">Click to browse images</span>
</span>
</label>
<div class="hidden">
<input ref="iefImageFileRef" @change="handleFileUpload" onclick="javascript:void(0)" type="file" id="ief-image-input" name="ief-image-input" />
</div>
<div :class="{ 'hidden': imageUploadProgress === -1 }" class="-bottom-1.5 absolute h-1 bg-digg-blue" :style="{ width: imageUploadProgress + '%' }"></div>
</div>
</div>
<header class="relative">
<inline-content-editable @keyup="handleKeyupKicker" @keydown.tab="toggleTitlePlaceholder($event)" @blur="toggleKickerPlaceholder($event)" @click="toggleKickerPlaceholder($event)" v-model="kicker" maxlength="64" class=" outline-none text-xss tracking-widest leading-5 uppercase text-digg-gray font-bold"></inline-content-editable>
<inline-content-editable @keyup="handleKeyupTitle" @keydown.tab="toggleDescriptionPlaceholder($event)" @blur="toggleTitlePlaceholder($event)" @click="toggleTitlePlaceholder($event)" v-model="title" maxlength="255" class=" outline-none mb-1 font-bold _text-base text-xl leading-tight text-digg-gray-darker hover:text-primary-text"></inline-content-editable>
</header>
<inline-content-editable @keyup="handleKeyupDescription" @blur="toggleDescriptionPlaceholder($event)" @click="toggleDescriptionPlaceholder($event)" v-model="description" maxlength="255" class=" outline-none text-sm text-digg-gray-dark font-normal mb-3"></inline-content-editable>
<div class="mb-2" v-if="submissionType == 'link'">
<a href="#" class="text-xs text-digg-gray-lighter" :title="url">{{ concatenatedUrl }}</a>
</div>
<div v-if="statusShowingCharacterLimit" class="rounded-full py-1 px-2 inline-block text-xs bg-digg-gray-lightest">
<div class="justify-center items-center flex">
<span class="inline-block text-digg-gray-dark">
{{ characterCount }}/{{ characterLimit }}
</span>
</div>
</div>
</div>
<div v-if="submissionType == 'post' || submissionType == 'link'" class="relative w-full mb-4 md:mb-0 md:w-24 md:h-24 flex-shrink-0 order-first md:order-last">
<label for="ief-image-input" class="cursor-pointer">
<span class="bg-digg-blue absolute top-2 right-2 flex justify-center items-center rounded-full w-6 h-6">
<svg height="14px" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" viewBox="0 0 22 22">
<path d="M8,0 L14,0 L14,3 L8,3 L8,0 Z M8,5 L14,5 L14,19 L11,22 L8,19 L8,5 Z" fill="#fff" transform="translate(11.000000, 11.000000) rotate(45.000000) translate(-11.000000, -11.000000) " /></g>
</svg>
</span>
<img :src="imageUrl" :alt="title" class="w-full h-56 md:h-24 rounded object-cover max-w-none max-h-none bg-digg-gray-clear" />
</label>
<div class="hidden">
<input ref="iefImageFileRef" @change="handleFileUpload" onclick="javascript:void(0)" type="file" id="ief-image-input" name="ief-image-input" />
</div>
<div :class="{ 'hidden': imageUploadProgress === -1 }" class="-bottom-1.5 absolute h-1 bg-digg-blue" :style="{ width: imageUploadProgress + '%' }"></div>
</div>
</div>
<div class="border-t-digg-gray-lightest" v-if="submissionType == 'post' || (submissionType == 'image' && false)">
<textarea ref="additionalContentMdeRef"></textarea>
</div>
<div v-if="statusShowDetailFields" class=" relative flex-col flex gap-4 p-4 border-t border-digg-gray-lightest">
<p>
<label class="mb-1 font-semibold block">Story overview</label>
<textarea maxlength="510" v-model="lede" placeholder="Add an example here" name="" rows="3" class="text-base w-full p-4 text-digg-gray rounded w-full outline-none focus:border-digg-blue-light border border-digg-gray-lightest"></textarea>
</p>
<p>
<label class="mb-1 font-semibold block">3 important details</label>
<textarea maxlength="510" v-model="points" placeholder="Add an example here" name="" rows="3" class="text-base w-full p-4 text-digg-gray rounded w-full outline-none focus:border-digg-blue-light border border-digg-gray-lightest"></textarea>
</p>
<p>
<label class="mb-1 font-semibold block">Social link</label>
<input maxlength="255" v-model="socialLink" placeholder="Original source twitter link" name="" type="text" class="text-base w-full p-3 text-digg-gray rounded w-full outline-none focus:border-digg-blue-light border border-digg-gray-lightest" />
</p>
</div>
<div class="flex flex-row justify-between py-2 px-4 border-t border-digg-gray-lightest">
<a v-if="submissionType == 'link' || submissionType == 'image'" @click.prevent="statusShowDetailFields = !statusShowDetailFields" href="#" class="text-xss tracking-widest leading-5 uppercase text-digg-gray font-bold">
<svg v-if="!statusShowDetailFields" xmlns="http://www.w3.org/2000/svg" class="h-4 w-4 mr-1 mb-0.5 text-bold inline" fill="none" viewBox="0 0 24 24" stroke="currentColor">
<path stroke-linecap="round" stroke-linejoin="round" stroke-width="2" d="M12 6v6m0 0v6m0-6h6m-6 0H6" />
</svg>
<svg v-if="statusShowDetailFields" xmlns="http://www.w3.org/2000/svg" class="h-4 w-4 mr-1 mb-0.5 text-bold inline" fill="none" viewBox="0 0 24 24" stroke="currentColor">
<path stroke-linecap="round" stroke-linejoin="round" stroke-width="2" d="M18 12H6" />
</svg>
<span v-if="!statusShowDetailFields">details</span>
<span v-else>details</span>
</a>
<div :class="{ 'w-full text-right': submissionType == 'post' }">
<a @click.prevent="handleCancelClick($event)" href="#" class="text-xss tracking-widest leading-5 uppercase text-digg-gray font-bold pr-2">cancel</a>
<a @click.prevent="handleSubmitForm($event)" :href="statusSubmitEnabled ? '#' : null" :class="{ 'opacity-50': !statusSubmitEnabled }" class="text-xss text-digg-blue tracking-widest leading-5 uppercase font-bold pl-2">
<span>save</span>
<svg v-if="statusSubmittingForm" class="inline-block animate-spin ml-1 -mt-1 h-4 w-4 text-digg-blue" xmlns="http://www.w3.org/2000/svg" fill="none" viewBox="0 0 24 24">
<circle class="opacity-25" cx="12" cy="12" r="10" stroke="currentColor" stroke-width="4"></circle>
<path class="opacity-75" fill="currentColor" d="M4 12a8 8 0 018-8V0C5.373 0 0 5.373 0 12h4zm2 5.291A7.962 7.962 0 014 12H0c0 3.042 1.135 5.824 3 7.938l3-2.647z"></path>
</svg>
</a>
</div>
</div>
</div>
</div>
</div>
<article style="display:none" class="item-loading border border-digg-gray-lightest rounded p-4 mb-6 w-full">
<div class="animate-pulse flex space-x-4">
<div class="flex-1 space-y-8 py-1">
<div class="h-4 bg-digg-gray-lightest rounded w-3/4"></div>
<div class="space-y-2">
<div class="h-4 bg-digg-gray-lightest rounded"></div>
<div class="h-4 bg-digg-gray-lightest rounded w-5/6"></div>
</div>
</div>
<div class="bg-digg-gray-lightest h-12 w-12"></div>
</div>
</article>
<article class="w-full submitted-link-item" itemprop="mainEntity" itemscope itemtype="http://schema.org/Article" data-id="4d6606ad4c2344cc68e2183f6bda81ef">
<header class="w-full relative flex _mb-2 flex-col md:flex-row gap-6">
<div class="flex-grow md:order-first min-w-0 order-last">
<p class="text-xss tracking-widest leading-5 uppercase text-digg-gray font-bold break-words alternativeHeadline" itemprop="alternativeHeadline">ANON PLS</p>
<h1 class="font-bold text-xl text-digg-gray-darker mb-1 lg:text-3xl leading-6 break-words " itemprop="headline name">Deuxmoi's Identity Revealed, It's Morbin' Time And This Week's Other Best Memes, Ranked</h1>
<p class="mb-2 text-digg-gray-light text-xs leading-6">
<span class="font-medium text-xs mb-2 inline-block">
925
reads
</span>
<span class="pl-1 pr-1">|</span>
submitted by
<a itemprop="author publisher" itemscope itemtype="https://schema.org/Person" href="/@molly-bradley" class="author relative text-xs whitespace-nowrap rounded-full py-0.5 px-2 mr-1 leading-6 tracking-tighter text-digg-blue">
<span class="absolute inset-0 rounded-full opacity-5 namespace-primary-background"></span>
<span itemprop="name" class="namespace-primary-text">
Molly Bradley
</span>
</a>
<span>
<time itemprop="datePublished dateModified" datetime="2022-05-26T13:40:26Z GMT">40 minutes ago</time>
</span>
</p>
</div>
<div class="order-first md:order-last">
<figure class="relative h-56 md:w-24 md:h-24 w-full bg-gray-100">
<picture itemprop="primaryImageOfPage md:mb-2 image" itemscope itemtype="https://schema.org/ImageObject">
<source media="(min-width: 300px)" srcset="https://cdn.digg.com/submitted-links/419x224/1653572435-DFjybLGhL2.jpg">
<source media="(min-width: 800px)" srcset="https://cdn.digg.com/submitted-links/96x96/1653572435-DFjybLGhL2.jpg">
<img src="https://cdn.digg.com/submitted-links/96x96/1653572435-DFjybLGhL2.jpg" itemprop="url contentUrl" loading="lazy" alt="Deuxmoi's Identity Revealed, It's Morbin' Time And This Week's Other Best Memes, Ranked" class="w-full h-56 md:w-24 md:h-24  rounded object-cover" onerror="this.onerror=null;this.src='/fragments/namespace/static/fallback-image.png';">
</picture>
<div class="operations absolute top-0 right-0 text-right">
<span class="menu-toggle inline cursor-pointer bg-white py-1">
<svg class="transform inline" height="18" viewbox="0 0 48 48" width="18" xmlns="http://www.w3.org/2000/svg">
<path d="M14.83 16.42l9.17 9.17 9.17-9.17 2.83 2.83-12 12-12-12z"></path>
</svg>
</span>
<div class="border py-2 rounded rounded-r-none actions hidden flex flex-col text-left bg-white">
<div class="text-sm whitespace-nowrap cursor-pointer pointer-events-auto">
<span class="p-2 px-4 share block" data-href="/memes-ranked/link/deuxmoi-s-identity-revealed-it-s-morbin-time-and-this-week-s-other-best-memes-ranked-M3THxre5uV" data-type="copy" data-title="Deuxmoi's Identity Revealed, It's Morbin' Time And This Week's Other Best Memes, Ranked">Copy link</span>
</div>
</div>
</div>
</figure>
</div>
</header>
<script>

    (() => {
      let iframeHeight = 400;

      window.addEventListener('message', e => {
        if (e.data.data) {
          iframeHeight = e.data.data.height + 20;
          const iframe = document.querySelector('.iframe-media');
          if (iframe) {
            iframe.style.height = iframeHeight + 'px';
          }
        }
      });
    })();

  </script>
<div class="mb-2 text-base leading-6 text-digg-gray break-words ">This week, we've also got people dunking on new photos of Gorr the God Butcher in "Thor: Love and Thunder."</div>
<div class="mb-4">
<div class="share-story mt-2 flex items-center" data-id="4d6606ad4c2344cc68e2183f6bda81ef" data-type="submitted-link" data-url="&#x2F;memes-ranked&#x2F;link&#x2F;deuxmoi-s-identity-revealed-it-s-morbin-time-and-this-week-s-other-best-memes-ranked-M3THxre5uV" data-title="Deuxmoi&#x27;s&#x20;Identity&#x20;Revealed,&#x20;It&#x27;s&#x20;Morbin&#x27;&#x20;Time&#x20;And&#x20;This&#x20;Week&#x27;s&#x20;Other&#x20;Best&#x20;Memes,&#x20;Ranked">
<span data-controller="digg" class="link-open-signin-modal digg inline-block mr-1 cursor-pointer "></span>
<div data-diggs="0" class="digg-count"></div>
<span data-controller="save" class="link-open-signin-modal save inline-block mr-1 cursor-pointer "></span>
<a href="#comments">
<span class="comments inline-block mr-1 cursor-pointer"></span>
</a>
<span data-controller="facebook" class="facebook inline-block mr-1 cursor-pointer"></span>
<span data-controller="twitter" class="twitter inline-block mr-1 cursor-pointer"></span>
</div>
</div>
<hr class="mb-6 block">
<div itemprop="description" class="mb-4 lede">
<div class="text-sm text-digg-gray leading-6 additionalContent break-words">
<html><head></head><body><p>Here at Digg, we try our best to cover the most important and confounding memes that come across the timeline. But the web is littered with tons of great memes that never quite hit the mainstream and instead just bounce around the weird corners of Twitter or Reddit. Enter our recurring feature, Memes, Ranked.</p>
<p>This week, we've got Deuxmoi’s identity reveal, Gorr the God Butcher and “It’s Morbin’ time.”</p>
<br>
<h3>1. Deuxmoi’s Identity Revealed</h3>
<h4>The meme</h4>
<p>For a number of years now, people interested in celebrity culture have been fascinated by an anonymous social media persona called Deuxmoi that takes tips about celebrity sightings and rumors about their personal and professional lives, and posts them for all the world to see.</p>
<p>Almost all of the tips they post are anonymous, usually by request of the people who submit them: “anon pls” has become an in-joke with Deuxmoi fans, since the request accompanies even the blandest of gossip for which there’s no reason to need anonymity.</p>
<p>It also means that almost all of the sources are unverifiable and likely just some random people, which is one thing for celebrity sightings but leaves you wondering how many of the tips about celebs’ upcoming professional projects are remotely reliable.</p>
<p><img src="https://cdn.digg.com/wp-content/uploads/2022/05/26132731/anon.png" alt=""></p>
<p>Last week, thanks to a <a href="https://bnet.substack.com/p/who-is-deuxmoi?s=r">newsletter from writer Brian Feldman</a>, Deuxmoi’s identity is now known: it was launched by Meggie Kempner, granddaughter of socialite Nan Kempner, and Melissa Lovallo, who is probably the person still actively running the account. So Deuxmoi Twitter has been alight with a sort of surprised-but-not-surprised sentiment at the fact that Deuxmoi is also just some random people.</p>
<br>
<h4>Examples</h4>
<br>
<blockquote class="twitter-tweet"><p lang="en" dir="ltr">deuxmoi just being a some girl named melissa is taking me out 😭</p>— alex (@alex_abads) <a href="https://twitter.com/alex_abads/status/1528729735093751809?ref_src=twsrc%5Etfw">May 23, 2022</a></blockquote> <script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
<blockquote class="twitter-tweet"><p lang="en" dir="ltr">how are some people shocked that deuxmoi is run by a middle aged white woman that is literally exactly what i was expecting</p>— mia (@pcrekh) <a href="https://twitter.com/pcrekh/status/1528292019423936512?ref_src=twsrc%5Etfw">May 22, 2022</a></blockquote> <script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
<blockquote class="twitter-tweet"><p lang="en" dir="ltr">the biggest twist is that the woman running deuxmoi is apparently over 35 but writes like she's 22 <a href="https://t.co/vBGO9ZhpYd">https://t.co/vBGO9ZhpYd</a></p>— tatiana tenreyro (@tatianatenreyro) <a href="https://twitter.com/tatianatenreyro/status/1527664917804994564?ref_src=twsrc%5Etfw">May 20, 2022</a></blockquote> <script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
<blockquote class="twitter-tweet"><p lang="en" dir="ltr">deuxmoi’s identity got discovered and why does it feel like the gossip girl series finale</p>— gen z che diaz (@franlebow1tz) <a href="https://twitter.com/franlebow1tz/status/1527749399044030464?ref_src=twsrc%5Etfw">May 20, 2022</a></blockquote> <script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
<blockquote class="twitter-tweet"><p lang="en" dir="ltr">DeuxMoi being two middle aged trust fund women makes perfect sense. Imagine being so bad at nepotism that you are more successful being anonymous than using your last name. I’d be bitchy and mean too 🥲</p>— Boom (@TheDuchessBoom) <a href="https://twitter.com/TheDuchessBoom/status/1528403884229681153?ref_src=twsrc%5Etfw">May 22, 2022</a></blockquote> <script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
<blockquote class="twitter-tweet"><p lang="en" dir="ltr">deuxmoi thinking they gossip girl but ending up being dog with a blog is killing me</p>— tia witcher extraordinaire (@cursedhive) <a href="https://twitter.com/cursedhive/status/1528476578446987267?ref_src=twsrc%5Etfw">May 22, 2022</a></blockquote> <script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
<br>
<p><em>Molly Bradley</em></p>
<br>
<br>
<h3>2. Gorr The God Butcher</h3>
<h4>The meme</h4>
<p>I really did not think Twitter would pick Gorr The God Butcher, a niche Marvel comic book villain, to be the next meme. Sure, he’s the next bad guy in “Thor: Love And Thunder” and yes, a new trailer that dropped shows Christian Bale playing him for the first time. But out of all the things we saw, he’s the new meme? We’re gonna dunk on <em>him</em>?</p>
<p>Did no one see Natalie Portman’s arms as Lady Thor? Or naked Chris Hemsworth?? Or Tessa Thompson as the new king of Asgard??? Am I the only one not taking crazy pills around here????? Yes, Gorr is pure white and bald, we knew this from leaked images of the upcoming toyline months ago. Kratos from God of War is the same thing, why is this such a big deal.</p>
<p>You Twitter maniacs are something else. I give up, have your fun internet, the world is on fire, under water, and getting worse by the day. I figured you would all be more horny for the other characters but that’s fine, you do you.</p>
<br>
<h4>Examples</h4>
<br>
<blockquote class="twitter-tweet"><p lang="en" dir="ltr">Gorr the God Butcher over here making Voldemort look like a muppet baby <a href="https://t.co/g6PvgkS1MG">https://t.co/g6PvgkS1MG</a></p>— Chris Killian (@chriskillian) <a href="https://twitter.com/chriskillian/status/1528918557563707392?ref_src=twsrc%5Etfw">May 24, 2022</a></blockquote> <script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
<blockquote class="twitter-tweet"><p lang="en" dir="ltr">I tried to test how Gorr would've looked like without a nose<br>I think it was probably for the best they gave him a nose, he looks too much like Voldemort without it<a href="https://twitter.com/hashtag/Gorr?src=hash&amp;ref_src=twsrc%5Etfw">#Gorr</a> <a href="https://t.co/Pqa2JPPNaE">pic.twitter.com/Pqa2JPPNaE</a></p>— Luis (@ZorieZorieZorie) <a href="https://twitter.com/ZorieZorieZorie/status/1528923316806856704?ref_src=twsrc%5Etfw">May 24, 2022</a></blockquote> <script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
<blockquote class="twitter-tweet"><p lang="en" dir="ltr">Let’s be honest: If Gorr didn’t have a nose in Thor 4 he would have just looked like Voldemort.</p>— Robert Jefferson (@comicsexplained) <a href="https://twitter.com/comicsexplained/status/1529234444564897792?ref_src=twsrc%5Etfw">May 24, 2022</a></blockquote> <script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
<blockquote class="twitter-tweet"><p lang="en" dir="ltr">Why Voldemort look more like Gorr than the MCU version</p>— Kingfadedz 👑 (@RequiemFade) <a href="https://twitter.com/RequiemFade/status/1528933166060380161?ref_src=twsrc%5Etfw">May 24, 2022</a></blockquote> <script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
<blockquote class="twitter-tweet"><p lang="en" dir="ltr">Christian Bale’s Gorr looks like the lovechild of Voldemort and Uncle Fester <a href="https://t.co/YvEHgHxsFg">pic.twitter.com/YvEHgHxsFg</a></p>— Adam Best (@adamcbest) <a href="https://twitter.com/adamcbest/status/1528927658905686016?ref_src=twsrc%5Etfw">May 24, 2022</a></blockquote> <script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
<blockquote class="twitter-tweet"><p lang="en" dir="ltr">Gorr looks like voldemort , vader and valak had a threesome lmao <a href="https://twitter.com/hashtag/ThorLoveAndThunder?src=hash&amp;ref_src=twsrc%5Etfw">#ThorLoveAndThunder</a> <a href="https://twitter.com/hashtag/ChristianBale?src=hash&amp;ref_src=twsrc%5Etfw">#ChristianBale</a> <a href="https://t.co/V0A1h81Mj4">pic.twitter.com/V0A1h81Mj4</a></p>— . (@MSativa7) <a href="https://twitter.com/MSativa7/status/1528922752891117568?ref_src=twsrc%5Etfw">May 24, 2022</a></blockquote> <script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
<blockquote class="twitter-tweet"><p lang="en" dir="ltr">yall are saying gorr looks like voldemort but tell me these two are not literal twins <a href="https://t.co/BdDpquSbsE">pic.twitter.com/BdDpquSbsE</a></p>— soma ❤️⚡️ (@KILUC0RE) <a href="https://twitter.com/KILUC0RE/status/1528928969751339011?ref_src=twsrc%5Etfw">May 24, 2022</a></blockquote> <script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
<blockquote class="twitter-tweet"><p lang="en" dir="ltr">It doesn’t stink, it’s regular water <a href="https://t.co/1IGQwYiXUK">pic.twitter.com/1IGQwYiXUK</a></p>— I Think You Should Leave - Dangerous Nights Crew (@ITYSL_memes) <a href="https://twitter.com/ITYSL_memes/status/1529104263833882629?ref_src=twsrc%5Etfw">May 24, 2022</a></blockquote> <script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
<br>
<p><em>Jared Russo</em></p>
<br>
<br>
<h3>1. It’s Morbin’ Time</h3>
<h4>The meme</h4>
<p>With an anemic 17 percent rating on Rotten Tomatoes, Jared Leto couldn’t make audiences go see his weird vampire superhero film “Morbius” when it opened back in March but this month, the internet has given new life to the cursed Marvel movie thanks to a viral tweet by @RANK10YGO who claimed that the apocryphal catchphrase from the movie, “It’s Morbin time,” was their favorite scene.</p>
<br>
<blockquote class="twitter-tweet"><p lang="en" dir="ltr">the best part of Morbius was when he said "IT'S MORBIN' TIME" and morbed all over those guys</p>— Rata ✨ (@RANK10YGO) <a href="https://twitter.com/RANK10YGO/status/1510361009621450761?ref_src=twsrc%5Etfw">April 2, 2022</a></blockquote> <script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
<br>
<p>Weeks later, the “It’s Morbin time” gag once again picked up steam as numerous netizens began riffing with it and mischievously placing it into various memes.</p>
<br>
<h4>Examples</h4>
<br>
<blockquote class="twitter-tweet"><p lang="en" dir="ltr">when Morbius showed up during the post credits scene in the new Doctor Strange and said "hey Strange... it's morbin time" I cried tears of joy</p>— Elvis The Alien (@ElvisTheAlienTV) <a href="https://twitter.com/ElvisTheAlienTV/status/1522804943643578370?ref_src=twsrc%5Etfw">May 7, 2022</a></blockquote> <script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
<blockquote class="twitter-tweet"><p lang="en" dir="ltr">My favorite moment in Doctor Strange 2 was when Doctor Strange travelled to the Morbius universe and stopped Morbius from going "It's Morbin' Time!," leading to the collapse of the movie theater industry in another universe that relied on the trillion tickets sold for that film.</p>— Kars (@KaroshiMyriad) <a href="https://twitter.com/KaroshiMyriad/status/1522415391871365121?ref_src=twsrc%5Etfw">May 6, 2022</a></blockquote> <script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
<blockquote class="twitter-tweet"><p lang="en" dir="ltr">everyone knows about Morbius's signature catch phrase "it's morbin' time" but only true morbheads know about the one he uses when the fight is getting serious: "Alright, no More B.S."</p>— Wasp 💌 - Comms OPEN! (@ObsidianWasp) <a href="https://twitter.com/ObsidianWasp/status/1528577801678254080?ref_src=twsrc%5Etfw">May 23, 2022</a></blockquote> <script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>&nbsp;
<blockquote class="twitter-tweet"><p lang="en" dir="ltr">there’s so much misinformation abt morbius like if u told me “it’s morbin time” was a real line in the movie I’d believe u</p>— nina (@B6TGIRLS) <a href="https://twitter.com/B6TGIRLS/status/1526937908845740035?ref_src=twsrc%5Etfw">May 18, 2022</a></blockquote> <script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
<blockquote class="twitter-tweet"><p lang="en" dir="ltr">Schrodinger's Morbius<br><br>the line "It's Morbin time" simultaneously exists and does not in the movie because no one has seen the film to be sure</p>— Reluu (@RelusionH) <a href="https://twitter.com/RelusionH/status/1528480910320058369?ref_src=twsrc%5Etfw">May 22, 2022</a></blockquote> <script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
<blockquote class="twitter-tweet"><p lang="en" dir="ltr">it’s morbin time! <a href="https://t.co/PO0HDWUG1y">pic.twitter.com/PO0HDWUG1y</a></p>— transgender marx (@JUNlPER) <a href="https://twitter.com/JUNlPER/status/1529271817264844800?ref_src=twsrc%5Etfw">May 25, 2022</a></blockquote> <script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
<blockquote class="twitter-tweet"><p lang="en" dir="ltr">The guy who made the "it's morbin' time" tweet has made more of a cultural impact than the entire fucking movie</p>— Crimson Mayhem #NewDeal4Animation (@Crimson_Mayhem_) <a href="https://twitter.com/Crimson_Mayhem_/status/1529300302125363201?ref_src=twsrc%5Etfw">May 25, 2022</a></blockquote> <script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
<blockquote class="twitter-tweet"><p lang="en" dir="ltr">What if Morbius took the gauntlet, snapped, and said "It's Morbin time" <a href="https://t.co/Qx0AAVJha9">https://t.co/Qx0AAVJha9</a></p>— Underscore "The Man the Myth the Morbius" Zeus (@UnderscoreZeus) <a href="https://twitter.com/UnderscoreZeus/status/1526397708428115968?ref_src=twsrc%5Etfw">May 17, 2022</a></blockquote> <script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
<br>
<p>But the coup de grace came from KFC, that delivered their own indelible Morbin tweet.</p>
<br>
<blockquote class="twitter-tweet"><p lang="en" dir="ltr">morbin time <a href="https://t.co/SxUyyZ1CvJ">pic.twitter.com/SxUyyZ1CvJ</a></p>— KFC (@KFC_ES) <a href="https://twitter.com/KFC_ES/status/1529451814910939138?ref_src=twsrc%5Etfw">May 25, 2022</a></blockquote> <script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
<br>
<p><em>James Crugnale</em></p>
<br>
<br>
<p>And if you're hungry for more memes, <a href="https://digg.com/memes-ranked/link/cara-delevingne-is-watching-you-and-this-week-s-other-best-memes-ranked-IMDcSlTItu">here's the last edition of "The Week's Best Memes, Ranked”</a>, where we rank Cara Delevingne creeping on Megan Thee Stallion, Julia Fox’s joots and “Why isn’t it possible?”</p>
</body></html>
</div>
</div>
</article>
<section>
<section class="comments-grid mb-12 block">
<a name="comments"></a>
<h2 class="mb-4 mt-8 font-bold text-xl leading-6 text-digg-gray-darker">Comments</h2>
<div class="require-login">
<p>
<a class="bg-white text-digg-blue border border-digg-blue text-center px-6 py-3 rounded-full cursor-pointer inline-block _hover:bg-digg-blue _hover:text-white namespace-primary-border namespace-primary-text link-open-signin-modal">Login to leave a comment</a>
</p>
</div>
<div class="comments-list">
<ol>
</ol>
<style>
  .comments-list ol { margin-left: 20px }
  .comments-list > ol { margin-left: 0px }
</style>
</div>
</section>
</section>
<hr class="mb-6 block">
<section class="mb-6">
<div class="rounded-md p-6" style="background: linear-gradient(90deg, rgba(36,78,183,1) 0%, rgba(72,123,232,1) 100%);">
<div class="text-white font-semibold text-xl leading-tightbreak-words mb-3">Cut Through The Chaos With Digg Edition</div>
<p class="text-white leading-tight mb-4">We’ve curated the best of the Internet so you don’t have to spend hours scrolling.</p>
<p class="text-white leading-tight mb-4">Sign up for Digg’s daily morning newsletter to get the most interesting stories of the moment delivered directly to your inbox. Sent every morning.</p>
<form class="js-cm-form flex" id="subForm" action="https://www.createsend.com/t/subscribeerror?description=" method="post" data-id="2BE4EF332AA2E32596E38B640E905619C2D3DDA6623CF1E3F519A7CEFB513AD59540162AD4A40F3C8CEC207D09E382F7159FF1645299F532D824B2CE9FC65376">
<input autocomplete="Email" aria-label="Email" class="js-cm-email-input qa-input-email flex-grow rounded-l-md px-4 py-3" id="fieldEmail" maxlength="200" name="email" required="" type="email" placeholder="name@example.com">
<button class="bg-digg-blue-dark px-4 lg:px-6 rounded-r-md text-white" type="submit">Continue</button>
</form>
</div>
</section>
<script type="text/javascript" src="https://js.createsend1.com/javascript/copypastesubscribeformlogic.js"></script>
</section>
<aside class="flex-shrink-0 hidden xl:block w-80">
<div class="mb-8 bg-digg-gray-clear flex justify-center rounded">

<style>
          @media only screen and (min-width: 0px) and (min-height: 0px) {
            div[id^="bsa-zone_1632414084717-4_123456"] {
              min-width: 300px;
              min-height: 250px;
            }
          }

          @media only screen and (min-width: 757px) and (min-height: 0px) {
            div[id^="bsa-zone_1632414084717-4_123456"] {
              min-width: 300px;
              min-height: 250px;
            }
          }
        </style>
<div id="bsa-zone_1632414084717-4_123456" class=""></div>
</div>

<div class="mb-8">
<section class="invisible xl:visible p-4 pb-2 rounded namespace-primary-background-transparent">
<section class="flex items-center border-b-2 namespace-primary-border pb-3 mb-4">
<a href="/popular" title="Popular on Digg" class="block cursor-pointer flex-grow uppercase font-semibold namespace-primary-text text-xs">
<h2>Popular on Digg</h2>
</a>
<a href="/popular" title="Popular on Digg" class="block cursor-pointer namespace-primary-text">
<svg xmlns="http://www.w3.org/2000/svg" class="h-6 w-6" fill="none" viewBox="0 0 24 24" stroke="currentColor">
<path stroke-linecap="round" stroke-linejoin="round" stroke-width="2" d="M15 12a3 3 0 11-6 0 3 3 0 016 0z"></path>
<path stroke-linecap="round" stroke-linejoin="round" stroke-width="2" d="M2.458 12C3.732 7.943 7.523 5 12 5c4.478 0 8.268 2.943 9.542 7-1.274 4.057-5.064 7-9.542 7-4.477 0-8.268-2.943-9.542-7z"></path>
</svg>
</a>
</section>
<section>
<a class="item-popular" href="https://digg.com/larq/link/larq-filter-purevis-microplastics-GtLNeNxEeR" data-id="742304">
<article class="flex gap-2 mb-6">
<div class="flex-grow">
<h3 class="font-semibold text-digg-gray-darkest text-base font-sans pr-2 mb-2 leading-tight">Microplastics Are Everywhere But They Shouldn't Be In Your Drinking Water</h3>
<div class="text-digg-gray-light text-xs">
<p class="inline-block pr-2.5 mr-1 border-r border-solid border-digg-gray-light">
111.7k reads </p>
<p class="inline-block">
James Crugnale
</p>
</div>
</div>
<img class="h-12 w-12 object-cover rounded bg-digg-gray-clear" src="https://cdn.digg.com/wp-content/uploads/2022/05/17183045/48x48/pure-vis-bottle-larq.jpg" alt="Microplastics Are Everywhere But They Shouldn't Be In Your Drinking Water" onerror="this.onerror=null;this.src='/fragments/namespace/static/fallback-image.png';">
</article>
</a>
<a class="item-popular" href="https://amzn.to/3wKW8IA" data-id="f96dff57afab2be2da1b1e2b31f49f17">
<article class="flex gap-2 mb-6">
<div class="flex-grow">
<h3 class="font-semibold text-digg-gray-darkest text-base font-sans pr-2 mb-2 leading-tight">This Inflatable Lantern Folds Down Flat, Recharges In The Sun</h3>
<div class="text-digg-gray-light text-xs">
<p class="inline-block pr-2.5 mr-1 border-r border-solid border-digg-gray-light">
New
</p>
<p class="inline-block">
Grant Brunner </p>
</div>
</div>
<img class="h-12 w-12 object-cover rounded bg-digg-gray-clear" src="https://cdn.digg.com/submitted-links/48x48/1653417033-UKK0QTZ5Ab.jpg" alt="This Inflatable Lantern Folds Down Flat, Recharges In The Sun" onerror="this.onerror=null;this.src='/fragments/namespace/static/fallback-image.png';">
</article>
</a>
<a class="item-popular" href="https://tandem-shower-by-boona.kckb.st/abe4fb87" data-id="827995">
<article class="flex gap-2 mb-6">
<div class="flex-grow">
<h3 class="font-semibold text-digg-gray-darkest text-base font-sans pr-2 mb-2 leading-tight">Wash Up With Friends Thanks To This Tandem Shower</h3>
<div class="text-digg-gray-light text-xs">
<p class="inline-block pr-2.5 mr-1 border-r border-solid border-digg-gray-light">
102.6k reads </p>
<p class="inline-block">
Grant Brunner
</p>
</div>
</div>
<img class="h-12 w-12 object-cover rounded bg-digg-gray-clear" src="https://cdn.digg.com/wp-content/uploads/2020/02/11153816/48x48/1651693872-iB8pNz4dsA.webp" alt="Wash Up With Friends Thanks To This Tandem Shower" onerror="this.onerror=null;this.src='/fragments/namespace/static/fallback-image.png';">
</article>
</a>
<a class="item-popular" href="https://digg.com/news" data-id="1217268">
<article class="flex gap-2 mb-6">
<div class="flex-grow">
<h3 class="font-semibold text-digg-gray-darkest text-base font-sans pr-2 mb-2 leading-tight">/ News</h3>
<div class="text-digg-gray-light text-xs">
<p class="inline-block pr-2.5 mr-1 border-r border-solid border-digg-gray-light">
7.5k reads </p>
<p class="inline-block">
Molly Bradley
</p>
</div>
</div>
<img class="h-12 w-12 object-cover rounded bg-digg-gray-clear" src="https://cdn.digg.com/wp-content/uploads/2022/04/19002243/48x48/heres-the-booos.jpg" alt="/ News" onerror="this.onerror=null;this.src='/fragments/namespace/static/fallback-image.png';">
</article>
</a>
</section>
</section>
</div>
<div class="sticky top-36 flexbar-sticky-offset">
<article itemscope="" itemtype="http://schema.org/Article" data-id="namespaceSidebarAd" class="fp-vertical-story mb-2 md:mb-0"></article>
</div>
</aside>
</div>
</main>
<footer class="px-4 lg:px-8 md:px-0 mt-8 mb-4 pt-4 flex flex-col items-center justify-center md:flex-row text-sm text-digg-gray-light border-t border-digg-gray-lightest border-solid">
<nav class="flex-auto mb-2 md:mb-0 text-center md:text-left">
<a class="mr-3 hover:text-digg-blue" href="/about">About</a>
<a class="mr-3 hover:text-digg-blue" href="/faq">FAQ</a>
<a class="mr-3 hover:text-digg-blue" href="/advertising">Advertise</a>
<a class="mr-3 hover:text-digg-blue" href="/community-guidelines">Community Guidelines</a>
<a class="mr-3 hover:text-digg-blue chrome" href="https://chrome.google.com/webstore/detail/digg-new-tab-extension/ifhmmfkaojalpgphoaknehmekeoilfhh" target="_blank" rel="noreferrer">
<div class="inline-flex items-baseline">
<svg class="mr-1 pt-1" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 512.003 512.003" width="16" height="16">
<path d="M61.818 89.204c119.008-138.496 339.68-111.168 422.144 50.624-58.08.032-148.992-.032-198.24 0-35.712 0-58.784-.8-83.744 12.352-29.344 15.456-51.52 44.096-59.232 77.76L61.818 89.204z" fill="#f44336" />
<path d="M170.842 256.02c0 46.944 38.176 85.12 85.088 85.12s85.088-38.176 85.088-85.12-38.176-85.12-85.088-85.12c-46.944-.032-85.088 38.176-85.088 85.12z" fill="#2196f3" />
<path d="M288.922 367.444c-47.744 14.176-103.648-1.536-134.24-54.4-23.36-40.32-85.12-147.872-113.152-196.8C-56.774 266.9 27.93 472.18 206.362 507.22l82.56-139.776z" fill="#4caf50" />
<path d="M334.938 170.868c39.776 36.992 48.448 96.896 21.504 143.328-20.288 35.008-85.088 144.352-116.48 197.28 183.84 11.328 317.856-168.832 257.312-340.64l-162.336.032z" fill="#ffc107" />
</svg>
<span class="text-digg-blue">Get the Digg New Tab Extension</span>
</div>
</a>
</nav>
<nav class="flex-auto md:text-right text-center md:text-left">
<a class="ml-3 hover:text-digg-blue" href="/tos">Terms</a>
<a class="ml-3 hover:text-digg-blue" href="/privacy">Privacy</a>
<a class="ml-3 hover:text-digg-blue" href="/">&copy; 2022 Digg</a>
</nav>
</footer>
</div>
<section class="signin-modal hidden fixed bg-gray-500 z-50 top-0 left-0 right-0 bottom-0 bg-opacity-25 text-base" data-return-to="">
<div class="placeholder relative flex flex-col shadow-sm bg-white sm:fixed sm:left-1/2 flex m-6 sm:m-24 sm:w-128 sm:-mx-64">
<a href="#" class="link-close-signin-modal absolute top-4 right-4">
<svg class="" xmlns="http://www.w3.org/2000/svg" width="26" height="26" viewBox="0 0 24 24">
<path d="M18.717 6.697l-1.414-1.414-5.303 5.303-5.303-5.303-1.414 1.414 5.303 5.303-5.303 5.303 1.414 1.414 5.303-5.303 5.303 5.303 1.414-1.414-5.303-5.303z" />
</svg>
</a>
<div class="step step-signin hidden signin-buttons p-12 pt-10 w-full">
<div class="p-12 block bg-white w-full text-center">
<svg class="inline-block" viewBox="0 0 47 27" width="47" height="27" xmlns="http://www.w3.org/2000/svg" aria-label="digg.com">
<path d="M5.025 10.025H7V17H5.025v-6.975zM0 21h12V0H7v6H0v15zM14 6h5v15h-5zm0-6h5v4h-5zm12 10h2v7h-2v-7zm-5 11h7v2h-7v4h12V6H21v15zm19-11h2v7h-2v-7zm-5 11h7v2h-7v4h12V6H35v15z" fill="#1B1A19" fill-rule="evenodd"></path>
</svg>
</div>
<p class="text-lg leading-7 pb-6 text-digg-gray-light text-center">Sign in to your Digg account.</p>
<p class="mb-6">
<a class="px-4 py-2 w-full signin-twitter-link bg-white text-brand-twitter border border-brand-twitter text-center rounded-full cursor-pointer flex items-center">
<svg class="flex-none" width="20" height="20" viewBox="0 0 22 22" fill="none" xmlns="http://www.w3.org/2000/svg">
<path fill-rule="evenodd" clip-rule="evenodd" d="M23.9985 2.24758C23.0996 2.63383 22.1467 2.88812 21.171 3.00212C22.1985 2.40281 22.9676 1.46106 23.3355 0.35174C22.3684 0.908636 21.3107 1.30102 20.208 1.51201C19.7476 1.03357 19.1909 0.65243 18.5726 0.392309C17.9543 0.132189 17.2876 -0.00134665 16.614 1.02378e-05C15.8718 -0.000848149 15.1389 0.161704 14.4704 0.475493C13.8019 0.789281 13.215 1.24617 12.7537 1.81195C12.2924 2.37772 11.9687 3.03772 11.8067 3.7425C11.6447 4.44728 11.6488 5.17858 11.8185 5.88163C9.86108 5.78564 7.94621 5.29069 6.1979 4.42885C4.44959 3.56701 2.90682 2.35748 1.6695 0.878605C1.23011 1.60889 1.00011 2.4405 1.0035 3.28671C1.0035 4.9505 1.8735 6.41288 3.1935 7.27104C2.41167 7.24699 1.64702 7.04185 0.963 6.67266V6.73104C0.963 9.05158 2.658 10.9897 4.9125 11.4305C4.18718 11.6196 3.42742 11.6476 2.6895 11.5122C3.00419 12.4642 3.6168 13.2967 4.44165 13.8934C5.26651 14.49 6.26237 14.8209 7.29 14.8398C5.54498 16.1699 3.39125 16.891 1.1745 16.8874C0.782023 16.8877 0.389861 16.8658 0 16.8217C2.252 18.2281 4.87206 18.9748 7.548 18.973C16.605 18.973 21.558 11.6771 21.558 5.34747C21.558 5.13877 21.552 4.93298 21.543 4.7272C22.507 4.04932 23.339 3.20964 24 2.24758H23.9985Z" fill="#00ACED"></path>
</svg>
<span class="flex-1 font-medium text-brand-twitter">Sign in with Twitter</span>
</a>
</p>
<p>
<a class="px-4 py-2 w-full signin-google-link bg-white text-brand-google border border-brand-google text-center rounded-full cursor-pointer flex items-center">
<svg class="flex-none" width="20" height="20" viewBox="0 0 22 22" fill="none" xmlns="http://www.w3.org/2000/svg">
<path d="M10.9998 4.55601C12.5731 4.55601 13.9825 5.09734 15.0931 6.15601L18.1371 3.11068C16.2891 1.39068 13.8758 0.333344 10.9998 0.333344C9.02278 0.33292 7.08459 0.882224 5.40178 1.91988C3.71898 2.95754 2.35784 4.44267 1.47046 6.20934L5.01713 8.96001C5.85713 6.43068 8.21712 4.55601 10.9998 4.55601Z" fill="#EA4335"></path>
<path d="M21.2133 11.244C21.2133 10.5467 21.1467 9.87066 21.044 9.22266H11V13.2307H16.7507C16.6263 13.8771 16.3744 14.4923 16.0098 15.0403C15.6451 15.5884 15.1749 16.0583 14.6267 16.4227L18.0627 19.0893C20.0667 17.2307 21.2133 14.484 21.2133 11.244Z" fill="#4285F4"></path>
<path d="M5.01327 13.04C4.79236 12.3824 4.67847 11.6937 4.67594 11C4.67594 10.2893 4.79594 9.60399 5.01327 8.95999L1.4666 6.20932C0.719096 7.6955 0.330905 9.33641 0.333271 11C0.330097 12.6641 0.719773 14.3055 1.4706 15.7907L5.01327 13.04Z" fill="#FBBC05"></path>
<path d="M10.9999 21.6667C13.8799 21.6667 16.3026 20.72 18.0626 19.084L14.6266 16.4174C13.6706 17.0627 12.4399 17.44 10.9999 17.44C8.21722 17.44 5.85722 15.564 5.01322 13.036L1.46655 15.7867C2.35442 17.5542 3.71611 19.04 5.39956 20.0783C7.08302 21.1167 9.02197 21.6666 10.9999 21.6667Z" fill="#34A853"></path>
</svg>
<span class="flex-1 font-medium text-brand-google">Sign in with Google</span>
</a>
</p>
<p class="pt-7 text-digg-gray-light text-center">
By signing in you agree with our<br /><a class="text-digg-blue leading-7" href="/tos">communications and usage terms</a>.
</p>
<p class="pt-7 text-digg-gray-light text-center">Not a member yet? <a class="text-digg-blue link-open-signup-modal" href="#">Sign up</a></p>
</div>
<div class="step welcome block p-12 w-full">
<h2 class="text-2xl font-extrabold">👋 Welcome to Digg</h2>
<p class="text-digg-gray pt-4 leading-6">Thanks for creating an account! Your accounts lets you Digg (upvote) stories, save stories to revisit later, and more.</p>
<hr class="py-1 my-4">
<h2 class="text-2xl font-extrabold">📩 Stay up-to-date</h2>
<p class="pt-4 leading-6 text-digg-gray">Email will be sent to: <span class="email"></span></p>
<p class="pt-4 leading-6 text-digg-gray">Select the newsletters you’d like to receive. You can change your subscriptions any time in your user settings.</p>
<div class="pt-4 subscriptions">
<div class="my-2 text-digg-gray">
<label for="99c1768583595c9420dcb59fefe47d7b">
<input type="checkbox" id="99c1768583595c9420dcb59fefe47d7b" name="subscriptions[]" value="99c1768583595c9420dcb59fefe47d7b">
<span class="pl-2">Daily morning newsletter</span>
</label>
</div>
<div class="my-2 text-digg-gray">
<label for="a46957e14c2e7ef0508f201895120a67">
<input type="checkbox" id="a46957e14c2e7ef0508f201895120a67" name="subscriptions[]" value="a46957e14c2e7ef0508f201895120a67">
<span class="pl-2">Afternoon video roundup</span>
</label>
</div>
<div class="my-2 text-digg-gray">
<label for="6efe481b7e95b4d75bd171927b232147">
<input type="checkbox" id="6efe481b7e95b4d75bd171927b232147" name="subscriptions[]" value="6efe481b7e95b4d75bd171927b232147">
<span class="pl-2">Bitcoin</span>
</label>
</div>
<div class="my-2 text-digg-gray">
<label for="a6073cbbdaaa1f73ff6dbdf99b643849">
<input type="checkbox" id="a6073cbbdaaa1f73ff6dbdf99b643849" name="subscriptions[]" value="a6073cbbdaaa1f73ff6dbdf99b643849">
<span class="pl-2">Long Reads</span>
</label>
</div>
</div>
<p class="flex pt-4">
<a href="#" class="welcome-link-submit px-4 py-2 bg-white text-digg-blue border border-digg-blue text-center rounded-full cursor-pointer inline-block hover:bg-digg-blue hover:text-white">Confirm and continue</a>
</p>
</div>
<div class="step completed block p-12 w-full">
<h2 class="text-2xl font-extrabold">🎉 You’re all set!</h2>
<p class="text-digg-gray pt-4 leading-6">Enjoy your new account! As a reminder, you can change your profile and email settings in your profile.</p>
<p class="sm:flex pt-4">
<a href="#" class="completed-link-close px-4 py-2 sm:inline-block bg-white text-digg-blue border border-digg-blue text-center rounded-full cursor-pointer inline-block hover:bg-digg-blue hover:text-white">Return to browsing</a>
<a href="/account/edit" class="mt-4 sm:mt-0 sm:ml-3 px-4 py-2 sm:inline-block bg-white text-digg-blue border border-digg-blue text-center rounded-full cursor-pointer inline-block hover:bg-digg-blue hover:text-white">View account</a>
</p>
</div>
</div>
</section>
<section class="signup-modal hidden fixed bg-gray-500 z-50 top-0 left-0 right-0 bottom-0 bg-opacity-25 text-base" data-return-to="">
<div class="placeholder relative flex flex-col shadow-sm bg-white sm:fixed sm:left-1/2 flex m-6 sm:m-24 sm:w-128 sm:-mx-64">
<a href="#" class="link-close-signup-modal absolute top-4 right-4">
<svg class="" xmlns="http://www.w3.org/2000/svg" width="26" height="26" viewBox="0 0 24 24">
<path d="M18.717 6.697l-1.414-1.414-5.303 5.303-5.303-5.303-1.414 1.414 5.303 5.303-5.303 5.303 1.414 1.414 5.303-5.303 5.303 5.303 1.414-1.414-5.303-5.303z" />
</svg>
</a>
<div class="step step-signup hidden signup-buttons p-12 pt-10 w-full">
<div class="p-12 block bg-white w-full text-center">
<svg class="inline-block" viewBox="0 0 47 27" width="47" height="27" xmlns="http://www.w3.org/2000/svg" aria-label="digg.com">
<path d="M5.025 10.025H7V17H5.025v-6.975zM0 21h12V0H7v6H0v15zM14 6h5v15h-5zm0-6h5v4h-5zm12 10h2v7h-2v-7zm-5 11h7v2h-7v4h12V6H21v15zm19-11h2v7h-2v-7zm-5 11h7v2h-7v4h12V6H35v15z" fill="#1B1A19" fill-rule="evenodd"></path>
</svg>
</div>
<p class="text-lg leading-7 pb-6 text-digg-gray-light text-center">Let's get started by creating your<br />account.</p>
<p class="mb-6">
<a class="px-4 py-2 w-full signup-twitter-link bg-white text-brand-twitter border border-brand-twitter text-center rounded-full cursor-pointer flex items-center">
<svg class="flex-none" width="20" height="20" viewBox="0 0 22 22" fill="none" xmlns="http://www.w3.org/2000/svg">
<path fill-rule="evenodd" clip-rule="evenodd" d="M23.9985 2.24758C23.0996 2.63383 22.1467 2.88812 21.171 3.00212C22.1985 2.40281 22.9676 1.46106 23.3355 0.35174C22.3684 0.908636 21.3107 1.30102 20.208 1.51201C19.7476 1.03357 19.1909 0.65243 18.5726 0.392309C17.9543 0.132189 17.2876 -0.00134665 16.614 1.02378e-05C15.8718 -0.000848149 15.1389 0.161704 14.4704 0.475493C13.8019 0.789281 13.215 1.24617 12.7537 1.81195C12.2924 2.37772 11.9687 3.03772 11.8067 3.7425C11.6447 4.44728 11.6488 5.17858 11.8185 5.88163C9.86108 5.78564 7.94621 5.29069 6.1979 4.42885C4.44959 3.56701 2.90682 2.35748 1.6695 0.878605C1.23011 1.60889 1.00011 2.4405 1.0035 3.28671C1.0035 4.9505 1.8735 6.41288 3.1935 7.27104C2.41167 7.24699 1.64702 7.04185 0.963 6.67266V6.73104C0.963 9.05158 2.658 10.9897 4.9125 11.4305C4.18718 11.6196 3.42742 11.6476 2.6895 11.5122C3.00419 12.4642 3.6168 13.2967 4.44165 13.8934C5.26651 14.49 6.26237 14.8209 7.29 14.8398C5.54498 16.1699 3.39125 16.891 1.1745 16.8874C0.782023 16.8877 0.389861 16.8658 0 16.8217C2.252 18.2281 4.87206 18.9748 7.548 18.973C16.605 18.973 21.558 11.6771 21.558 5.34747C21.558 5.13877 21.552 4.93298 21.543 4.7272C22.507 4.04932 23.339 3.20964 24 2.24758H23.9985Z" fill="#00ACED"></path>
</svg>
<span class="flex-1 font-medium text-brand-twitter">Sign up with Twitter</span>
</a>
</p>
<p class="mb-6">
<a class="px-4 py-2 w-full signup-facebook-link bg-white text-brand-facebook border border-brand-facebook text-center rounded-full cursor-pointer flex items-center">
<svg class="flex-none" width="20" height="20" viewBox="0 0 22 22" fill="none" xmlns="http://www.w3.org/2000/svg">
<path fill-rule="evenodd" clip-rule="evenodd" d="M20.4895 0.333496H1.51083C1.19858 0.333496 0.899122 0.457536 0.678329 0.678329C0.457536 0.899122 0.333496 1.19858 0.333496 1.51083V20.4895C0.333496 21.1402 0.860163 21.6668 1.51083 21.6668H11.7282V13.4055H8.94683V10.1868H11.7282V7.8095C11.7282 5.05483 13.4108 3.55616 15.8695 3.55616C17.0468 3.55616 18.0588 3.6415 18.3535 3.6815V6.5615H16.6468C15.3135 6.5615 15.0535 7.19616 15.0535 8.1295V10.1828H18.2402L17.8268 13.4042H15.0535V21.6668H20.4895C20.8017 21.6668 21.1012 21.5428 21.322 21.322C21.5428 21.1012 21.6668 20.8017 21.6668 20.4895V1.51083C21.6668 1.19858 21.5428 0.899122 21.322 0.678329C21.1012 0.457536 20.8017 0.333496 20.4895 0.333496Z" fill="#3B5998"></path>
</svg>
<span class="flex-1 font-medium text-brand-facebook">Sign up with Facebook</span>
</a>
</p>
<p>
<a class="px-4 py-2 w-full signup-google-link bg-white text-brand-google border border-brand-google text-center rounded-full cursor-pointer flex items-center">
<svg class="flex-none" width="20" height="20" viewBox="0 0 22 22" fill="none" xmlns="http://www.w3.org/2000/svg">
<path d="M10.9998 4.55601C12.5731 4.55601 13.9825 5.09734 15.0931 6.15601L18.1371 3.11068C16.2891 1.39068 13.8758 0.333344 10.9998 0.333344C9.02278 0.33292 7.08459 0.882224 5.40178 1.91988C3.71898 2.95754 2.35784 4.44267 1.47046 6.20934L5.01713 8.96001C5.85713 6.43068 8.21712 4.55601 10.9998 4.55601Z" fill="#EA4335"></path>
<path d="M21.2133 11.244C21.2133 10.5467 21.1467 9.87066 21.044 9.22266H11V13.2307H16.7507C16.6263 13.8771 16.3744 14.4923 16.0098 15.0403C15.6451 15.5884 15.1749 16.0583 14.6267 16.4227L18.0627 19.0893C20.0667 17.2307 21.2133 14.484 21.2133 11.244Z" fill="#4285F4"></path>
<path d="M5.01327 13.04C4.79236 12.3824 4.67847 11.6937 4.67594 11C4.67594 10.2893 4.79594 9.60399 5.01327 8.95999L1.4666 6.20932C0.719096 7.6955 0.330905 9.33641 0.333271 11C0.330097 12.6641 0.719773 14.3055 1.4706 15.7907L5.01327 13.04Z" fill="#FBBC05"></path>
<path d="M10.9999 21.6667C13.8799 21.6667 16.3026 20.72 18.0626 19.084L14.6266 16.4174C13.6706 17.0627 12.4399 17.44 10.9999 17.44C8.21722 17.44 5.85722 15.564 5.01322 13.036L1.46655 15.7867C2.35442 17.5542 3.71611 19.04 5.39956 20.0783C7.08302 21.1167 9.02197 21.6666 10.9999 21.6667Z" fill="#34A853"></path>
</svg>
<span class="flex-1 font-medium text-brand-google">Sign up with Google</span>
</a>
</p>
<p class="pt-7 text-digg-gray-light text-center">
By signing up you agree with our<br /><a class="text-digg-blue leading-7" href="/tos">communications and usage terms</a>.
</p>
<p class="pt-7 text-digg-gray-light text-center">Already have an account? <a class="text-digg-blue link-open-signin-modal" href="#">Login</a></p>
</div>
<div class="step welcome block p-12 w-full">
<h2 class="text-2xl font-extrabold">👋 Welcome to Digg</h2>
<p class="text-digg-gray pt-4 leading-6">Thanks for creating an account! Your accounts lets you Digg (upvote) stories, save stories to revisit later, and more.</p>
<hr class="py-1 my-4">
<h2 class="text-2xl font-extrabold">📩 Stay up-to-date</h2>
<p class="pt-4 leading-6 text-digg-gray">Email will be sent to: <span class="email"></span></p>
<p class="pt-4 leading-6 text-digg-gray">Select the newsletters you’d like to receive. You can change your subscriptions any time in your user settings.</p>
<div class="subscriptions pt-4">
<div class="my-2 text-digg-gray">
<label for="99c1768583595c9420dcb59fefe47d7b">
<input type="checkbox" id="99c1768583595c9420dcb59fefe47d7b" name="subscriptions[]" value="99c1768583595c9420dcb59fefe47d7b">
<span class="pl-2">Daily morning newsletter</span>
</label>
</div>
<div class="my-2 text-digg-gray">
<label for="a46957e14c2e7ef0508f201895120a67">
<input type="checkbox" id="a46957e14c2e7ef0508f201895120a67" name="subscriptions[]" value="a46957e14c2e7ef0508f201895120a67">
<span class="pl-2">Afternoon video roundup</span>
</label>
</div>
<div class="my-2 text-digg-gray">
<label for="6efe481b7e95b4d75bd171927b232147">
<input type="checkbox" id="6efe481b7e95b4d75bd171927b232147" name="subscriptions[]" value="6efe481b7e95b4d75bd171927b232147">
<span class="pl-2">Bitcoin</span>
</label>
</div>
<div class="my-2 text-digg-gray">
<label for="a6073cbbdaaa1f73ff6dbdf99b643849">
<input type="checkbox" id="a6073cbbdaaa1f73ff6dbdf99b643849" name="subscriptions[]" value="a6073cbbdaaa1f73ff6dbdf99b643849">
<span class="pl-2">Long Reads</span>
</label>
</div>
</div>
<p class="center flex pt-4">
<a href="#" class="welcome-link-submit px-4 py-2 bg-white text-digg-blue border border-digg-blue text-center rounded-full cursor-pointer inline-block hover:bg-digg-blue hover:text-white">Confirm and continue</a>
</p>
</div>
<div class="step completed block p-12 w-full">
<h2 class="text-2xl font-extrabold">🎉 You’re all set!</h2>
<p class="text-digg-gray pt-4 leading-6">Enjoy your new account! As a reminder, you can change your profile and email settings in your profile.</p>
<p class="sm:flex pt-4">
<a href="#" class="completed-link-close px-4 py-2 sm:inline-block bg-white text-digg-blue border border-digg-blue text-center rounded-full cursor-pointer inline-block hover:bg-digg-blue hover:text-white">Return to browsing</a>
<a href="/account/edit" class="mt-4 sm:mt-0 sm:ml-3 px-4 py-2 sm:inline-block bg-white text-digg-blue border border-digg-blue text-center rounded-full cursor-pointer inline-block hover:bg-digg-blue hover:text-white">View account</a>
</p>
</div>
</div>
</section>
<script src="https://js.createsend1.com/javascript/copypastesubscribeformlogic.js"></script>

<script src="https://cdnjs.cloudflare.com/ajax/libs/fingerprintjs/0.5.3/fingerprint.min.js"></script>
<script>
    (() => {
            if (typeof Fingerprint === 'function') {
        const fingerprint = new Fingerprint().get();
        localStorage.setItem('diggUserId', fingerprint);
      }
          })();

  </script>
<script src="https://gnome.digg.com/library/tracker.js?v=1655212101" async></script>

<script>
    window.diggTargetAttribute = '_blank';
  </script>

<script>
    let displayAds = true;

    if (typeof (Storage) !== 'undefined') {
      if (localStorage.getItem('disable-digg-ads')) {
        displayAds = false;
      }
    }
    var videoEmbedDiv = document.getElementsByClassName('embedd-code')[0],
      videoFrame = videoEmbedDiv ? videoEmbedDiv.getElementsByTagName('iframe')[0] : false,
      isRumble = videoFrame ? (videoFrame.className == 'rumble' ? true : false) : false;

    if (displayAds) {
      (function () {
        var bsa_optimize = document.createElement('script');
        bsa_optimize.type = 'text/javascript';
        bsa_optimize.async = true;
        bsa_optimize.src = 'https://cdn4.buysellads.net/pub/digg.js?' + (new Date() - new Date() % 960000);
        (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(bsa_optimize);
      })();
    }
    else {
      var dfp1 = document.createElement('script');
      dfp1.src = 'https://securepubads.g.doubleclick.net/tag/js/gpt.js';
      (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dfp1);
      var dfp2 = document.createElement('script');
      dfp2.src = 'https://imasdk.googleapis.com/js/sdkloader/gpt_proxy.js';
      (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dfp2);
      window.googletag = window.googletag || { cmd: [] };
      googletag.cmd.push(function () {
        googletag.defineSlot('/8691100/Digg_S2S_RightRail_Companion_ATF', [300, 250], 'div-gpt-ad-1568682532978-0')
          .addService(googletag.companionAds())
          .addService(googletag.pubads());
        googletag.companionAds().setRefreshUnfilledSlots(true);
        googletag.pubads().enableVideoAds();
        googletag.enableServices();
        googletag.display('div-gpt-ad-1568682532978-0');
      });
    }
  </script>
<script src="//m.servedby-buysellads.com/monetization.js?1594916485"></script>
<script>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</script>

<script>
    function getCookie(name) {
      var nameEQ = name + '=',
        ca = document.cookie.split(';');
      for (var i = 0; i < ca.length; i++) {
        var c = ca[i];
        while (c.charAt(0) == ' ')
          c = c.substring(1, c.length);
        if (c.indexOf(nameEQ) == 0)
          return c.substring(nameEQ.length, c.length);
      }
      return null;
    }

    function hideElementCheck(which) {
      if (getCookie(which))
        hideElement(which);
    }

    function hideElement(id) {
      var s = document.getElementById(id);
      if (typeof s !== 'undefined' && s != null)
        s.style.display = 'none';
    }
    function hideElementAndSetCookie(id, hours) {
      var s = document.getElementById(id);
      var now = new Date();
      now.setHours(now.getHours() + hours);
      if (typeof s !== 'undefined' && s != null)
        document.cookie = id + '=hide;expires=' + now.toGMTString() + '; SameSite=Lax; path=/';
      s.style.display = 'none';
    }
    hideElementCheck('subscribePromotion');
    hideElementCheck('subscribeBar');
  </script>

<script>
    (function (h, o, t, j, a, r) {
      h.hj = h.hj || function () { (h.hj.q = h.hj.q || []).push(arguments) };
      h._hjSettings = { hjid: 1965945, hjsv: 6 };
      a = o.getElementsByTagName('head')[0];
      r = o.createElement('script'); r.async = 1;
      r.src = t + h._hjSettings.hjid + j + h._hjSettings.hjsv;
      a.appendChild(r);
    })(window, document, 'https://static.hotjar.com/c/hotjar-', '.js?sv=');
  </script>
<script src="/fragments/components/main-navigation/static/main-navigation.js?v=1655212101"></script>
<script src="/fragments/components/main-navigation/static/signin-modal.js?v=1655212101"></script>
<script src="/fragments/components/main-navigation/static/signup-modal.js?v=1655212101"></script>
<script src="/fragments/components/main-navigation/static/update-sats-label.js?v=1655212101"></script>
<link rel="stylesheet" href="/fragments/namespace/static/simplemde.min.css?v=1655212101">
<link rel="stylesheet" href="/fragments/namespace/static/view-link.css?v=1655212101">
<link rel="stylesheet" href="/fragments/components/social-share/static/social-share.css?v=1655212101">
<script src="/fragments/components/social-share/static/social-share.js?v=1655212101" async></script>
<script src="/fragments/namespace/static/namespace-load-more.js?v=1655212101" async></script>
<script src="/fragments/namespace/static/namespace-comments.js?v=1655212101"></script>
<script src="/fragments/namespace/static/namespace-caret-menu.js?v=1655212101"></script>
<script src="/fragments/namespace/static/namespace-share.js?v=1655212101"></script>
<script src="/fragments/namespace/static/namespace-home.js?v=1655212101"></script>
<script>
  const namespaceId = '4b8acc13ef77e21e5e70a7f23f244885';
  const submittedLinkId = '4d6606ad4c2344cc68e2183f6bda81ef';
</script>
<script src="https://api.peruse.ai/static/peruse.min.js" data-pathname="/memes-ranked/link/deuxmoi-s-identity-revealed-it-s-morbin-time-and-this-week-s-other-best-memes-ranked-M3THxre5uV" data-article-query-selector=".submitted-link-item" data-wpm="300" async></script>
</body>
</html>
